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1.0 Online Student Course Requests 

If students in your district can log on to the Student portal to view their academic information, 
they can enter course selections for the coming school year. Automating student requests 
means you don’t have to manually add student course requests in order to build your master 
schedule for the next school year. 

Schools define course selection sheets (academic tracks) for different grade levels by subject 
area (track selection). Students make their course selections in the Student portal. 
Parents/Guardians with family portal access can monitor their child’s selections. Counselors and 
administrators can see and approve their requests in the School view. 

 

1.1 Preferences and Setup 

Pre-planning at the district and school levels prior to using online student course requesting is 
essential. Some important areas to consider are:  

 Will the district and/or schools accommodate more than one academic track type and for 

what purpose(s)? It is recommended that districts and schools use the one, Standard 

academic track type provided.  

 Who will manage the Academic Track Selection Subject Area reference codes? Both the 

district and the schools can create their own subject area codes. It is recommended that 

the subject area codes be created and managed at the district level for the schools to 

use. It is further recommended that the subject area codes created match the Enterprise 

course departments as this will make setup much easier. 

 Agreement should be reached as to processes regarding the copying of academic tracks 

among schools in the district. It is recommended that this process be managed at the 

district level. 

 Student and parent/guardian user accounts and management. This topic is beyond the 

scope of Module 5 but must be included in district/school planning for online student 

course requests. 

 At the school level, decisions will have to be made regarding the assigning of required 

courses when using online course requests. It is recommended that where students will 

be doing their course requests online, all required courses be assigned within the setup 

of track selection. 

 At the school level, decisions with regard to the number of maximum and minimum 

subject area selections will have to be determined for meaningful parameters. 

 At the school level, decisions will have to be made regarding when to open the online 

course selection window and for which grades. Schools may choose to space the online 

access for grades such that perhaps students going into grade 12 have access first, 11’s 

next and so on. 
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1.1.1 Online Student Course Request Checklist 

Preparing for student online course requests should follow the order of the checklist provided 
below. 

 Course catalogues for next school year complete 

 Build year context set in school details 

 Assign students’ Next School  

 Assign students’ Academic Track (type) – Standard (can only do so for Primary 

students) 

 Create or Copy Academic Track – School Course Selections Outline 

 Build Track Selections – Subject Areas 

 Create/distribute/manage student/parent accounts for portal access 

 Optional: Create school “Leading to Graduation” Page 

In order to enable students’ ability to do online course requests, the school course catalogue 
must be established for the build year (School View > Schedule > Courses, filter for Build Year) 
and the build year context must be set (School View > School > Setup > Details).  

Students will need their Next School assigned and should also have their Academic Track type 
(Standard) set. This is done in the School View > Student list, using the Pre-transition field set. 
Both of these fields are mass updateable and can also use modify list. Note that the Academic 
Track type field is not available from within the student’s details screen. 
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1.2 Student Portal and Course Requests 

Students will find doing online course requests very easy and it will save an enormous amount 
of time for data entry from course request sheets. Initial setup will be time consuming, however 
once complete it will carry over from one year to the next with very little modification likely 
necessary. 

Logging on to the portal, students will find course requests from My Info > Requests. The view 
defaults to the entry mode for course selection. Students can toggle to the request view mode 
by clicking on Exit entry mode, but this latter view is a read only window. Within the entry mode 
window students will find the Instructions block at the top of the window. Above this is a line 
indicating the next school year for which the requests are made, the number of primary and 
alternate requests selected, the percent scheduled and the total credits. 
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1.2.1 Primary Requests 

The middle blocks display the primary requests and the alternate requests. Primary requests 
refer to the student’s first choice course selections. These requests are broken down into 
subject areas. It is recommended that the subject areas match the Enterprise course 
departments. In the screenshot captures for this student going into grade 10, students are 
directed to have 8 primary requests and 2 alternate requests. Of the 8 primary requests, 5 of 
these are required and have been assigned as such; students cannot change these. Clicking on 
the select button of required courses will display the course with a greyed out check box and the 
status of Required. 

 

 

 Students in this example must however select 1 Mathematics and 2 optional, primary requests. 
Some subject areas may be configured to allow for the selection of direct alternates. 
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Making a course selection is done by clicking on the select button and following the subject area 
instructions provided. Students click in the subject(s) of their choice and click OK. 

 

 

1.2.2 Alternate Requests 

The students in this example will then also select 2 alternate requests from the Alternate 
requests block. These requests provide the load engine of the builder (and counsellors) the 
means of filling a student’s timetable should they not be scheduled into all of their primary 
requests. It is recommended that alternate requests use the subject area, Electives. This 
subject area is then populated with the grade appropriate choices for alternates; these can 
include any of the courses also found within subject areas for primary requests. 
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1.2.3 Notes for Counselor 

There is a field for students to include notes for the counsellor. It is recommended that students 
be encouraged to speak to a counsellor. This area may be a good means of making a request 
to discuss the student’s choices with their counsellor. There is no automated feature to notify 
the counsellor. The note is viewable as the student’s requests are reviewed. 

1.2.4 Posting 

Once the student has completed their course selection they should click on the Post button at 
the bottom of the window. Note that all selections are automatically saved, but posting will time 
stamp the submission. 

 

1.3 Parent Portal 

Student contacts identified as parents or guardians and who have family portal access checked 
in their details and have a user account, will have access to the course selection window. From 
Family View > Family > Schedule > Requests, parents will not only be able to view their child’s 
course requests but they have the ability to make selections and changes on behalf of their 
children in the same way as the student can. 

 

2.0 Academic Tracks 

Academic tracks, is the term used in MyEducation BC that refers to the school course selections 
outline for online student course requests. This is analogous to the student course request 
sheets common in a paper-based course selection process used in many schools. 

Terminology used in MyEducation BC online student course requests can be confusing. The 
following will help to address this. 

 Academic Track Type: Currently in MyEducation BC there is one track type, Standard. 

Students must be assigned an academic track type for online course requesting. This is 

confusing as the field name presented from the student list > Pre-transition field set is 

called Academic Track and not type. As we do not place students into academic tracks, 

the one type should be all that is necessary. Academic Track Type codes are defined in 

the reference tables, School View > Admin > Reference Tables > Academic Track Type 

> Codes. 
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 Academic Tracks: This term refers to the school course selections outline. Schools 

should only require one academic track as the outline will encompass each grade, the 

instructions as well as the subject areas and courses contained within. 

 Track Selections: Track selections are the grade level subject areas and the courses 

within each from which students make their selections. 

 Subject Areas: It is recommended that subject areas be defined at the district level to be 

used by each school. These are created in the reference table > Academic Track 

Selection Subject Area.   

 

2.1 Define Academic Tracks – School Course Selections Outline 

An academic track defines a set of possible course selections available to a specific group of 
students. They are analogous to the colored course selection sheets common in a paper-based 
course selection process. Define an academic track and courses that students can or must 
complete when assigned to that track. 

To define an academic track / Creating the course selections outline 

From School View > Schedule > Academic Tracks, go to Options > Add. 

Academic tracks can be copied; however, more than one track type would have to exist in order 
for this to be useful. To copy an existing track, select the track and click Details. On the Options 
menu, click Copy. Type a number to indicate the number of copies of the track you want to 
make. Generally, a single academic track should suffice. 

The Academic Track page appears: 

 

 A name is required for the academic track. In the example above, this track is named 

Valleyview Secondary Course Selections.  

 Type is also a required field. Typically as discussed above there will only be the one 

type, Standard. 
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 A minimum and maximum number of credits can be set for students. Users are 

cautioned that this applies to all students using online course requests; some students 

might only be selecting a few courses. For those needing only one or two courses it 

would likely be preferable for them to see a counsellor and have their requests manually 

entered. 

 Click the Secondary student only check box if checkbox if this selection sheet is for 

incoming secondary students only. 

 Use the Grade Levels area of the page to include all the grade levels that are part of the 

current track. Click Add to add a grade level, and do the following: 

o Click the drop-down to select a grade in the grade level column. 

o Type the instructions that appear for students in that grade level on their 

Requests page in the Student Portal. 

o In the StartDate and EndDate columns, define the date range in which students 

in this grade level can use the Student Portal to make their course selections. 

Note: The Grade Level selected is for next year’s grade as illustrated in the preceding 
screen capture. 
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2.2 Track Selections – Subject Areas 

Track selections are used to define the subject areas and courses within each, for a given grade 
that a student is allowed to choose from. Subject areas are defined in the ReferenceTables > 
Academic Track Selection Subject Area > Codes. Subject area codes should be created at the 
district level. 

Schools may wish to determine the order in which subject area selections appear in the student 
request window. By default, codes are displayed in the portal alphabetically and all have a 
sequence number of 0. School users can define the order of appearance by determining the 
sequence number of each code. This is set from within the details of each code or can be set 
from the Codes view in the default field set shown below. The SeqNo field can be set using 
Modify List. A sequence number value of zero is the highest. 

 

 

 

2.2.1 To define track selections/subject areas: 

From School View > Schedule > Academic Tracks, select your academic track. This won’t be 
necessary if you only have one. Then click on the Track Selections side tab > Options > Add. 

From the new academic track selection page: 

 Select the grade level for this track selection/subject area, required. 

 Set a sequence number here or from the field set if you wish to order the subject area 

selections. 

 Use the drop-down list to select the subject area. 

 Name can be the same as the subject area 

 Determine the maximum and minimum selections students can make in this subject 

area. Note that maximum is above the minimum on the page. 



 

Scheduling Modue 5 : Online Student Course Requests  v1.3 Page 13 

 For Alternate Requests, the lower block found on the student course request entry 

screen, check Alternate only. 

 Force Recommendations – leave blank 

 Allow direct alternates is useful for non-academic selections where students have a lot of 

choice. For example, in Fine Arts if the student doesn’t get Dance, then choose Drama 

as a direct alternate choice. 

 Complete the instructions field for this subject area. The text editor allows for many 

presentation options. 
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2.2.2 Course Selections 

The lower block of the track selection page is where the user adds the courses to the track 
selection/subject area.  

Clicking on Multi-Add and selecting the Department field; then doing Control-F and querying for 
the given department, allows for a much quicker means of choosing the courses. 

 

 

 

Users can re-order the selection of courses by dragging and dropping from the “stack”        icon 
next to the sequence number.  

 

 

Clicking on the hyperlinked SeqNo enables editing of the course record. Users are presented 
with the following editable fields: 

 

 SeqNo: This can be changed to re-order the presented list of courses. 

 Course Number / Course Description: Do not change these here as it will break the 

link to the courses in the catalogue and a blue exclamation mark will appear next to the 
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course code as a result. It is recommended to delete the unwanted course and select 

the correct one rather than changing a code and/or name. 

 Required: This is checked if the course is required, displaying for the student but not 

allowing any changes to be made. 

 Default: Check this setting if you want the current course to be selected by default; 

however, the student can change this request if they wish. 

 NeedApproval: This is just a flag that indicates to the student that they need approval 

from a counselor; it does not stop them from requesting the course. 

 LinkedCourseNumbers: This is a very powerful feature that allows the user to link 

courses when requesting one of a pair (or more). In the LinkedCourseNumbers field, 

type the code of the course or courses to be linked using a comma to separate when 

more than one course is linked. In example below, students who request MAT--12, 

Automotive Technology 12 must also take MAST-2A, Automotive Service Technician 12. 

When the latter is linked to the former, a request for one automatically assigns both 

requests.. 

 

 

 

Below is the Request page as viewed by the student. 

 

 

 

 

  



 

Scheduling Modue 5 : Online Student Course Requests  v1.3 Page 16 

2.3 Copy Academic Tracks and Track Selections 

If your school or another school in your district has created an academic track that would be 
helpful to share, you can make copies and push them to other schools, or pull other school 
tracks to your school. 

It is recommended that the copying of academic tracks be done at the district level as this can 
be either a push or pull option. It is worth noting that when using this feature, both the academic 
tracks selected and the accompanying track selections are also copied. This will allow districts 
to set up one school and then copy the setup to other schools. 

 

2.3.1 To copy academic tracks between schools: 

From School View > Schedule > Academic Tracks go to Options > Copy. The Copy Academic 
Tracks dialog box appears. 

 

 Copy Mode allows for the push or pull of academic tracks 

 Destination/Source School(s) gives the user the ability to select multiple schools in the 

district. 

 The Name block identifies available academic tracks. 

 Be sure to check, Exclude courses missing from school course catalog to avoid copying 

courses that may not exist or wish to be offered at the selected school(s). 

Note: When copying Academic Tracks, schools acquiring copies must review all areas of 
academic tracks to ensure that they meet the school’s requirements. 
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Appendix A: Academic Track Selections – Definitions 

Field Description 

SeqNo Type the sequence number. This number determines where the course appears on 
the Student Request entry page. If you do not determine sequence numbers, the 
system lists courses by course number. 

Click the  to drag and drop the courses in the order you want them within the list. 

If a course number no longer exists in the school’s course catalog, an exclamation 
point appears next to the SeqNo. 

Course Number / 
Course Description 

Type the course number and course description. 

Required? Select this checkbox if every student on this track must select this course. Students 
cannot deselect this course. 

 

When a student first views their requests for a build year, required courses appear as 
requests already entered. 

Default? Select this checkbox if you want the course to be the default selection for a student 
on this track. The student entering requests can select another course. 

 

When a student first views their requests for a build year, default courses appear as 
requests already entered. 

NeedApproval? Select this checkbox if there is an additional approval form or process needed when 
the course is selected. 

 

MyEd stores this value with every request for the course; 

when a student selects this course, the request displays a Y in the Needs Approval? 
column. 

LinkedCourseNumbers Type the list of courses that must be selected together with the current course. 
Separate the course numbers with commas (for example, 101,352B,455). 

 

 

 

 

 


