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1.0 Scenarios 

A build scenario defines the structure of the schedule you would like to build for next year, 
including the schedule terms, number of periods, and number of days per cycle. 

You can create several build scenarios. For example, you might use a scenario to build your 
traditional master schedule. Even if you are happy with the schedule you build, you might want 
to continue to tweak it to see if you can get a better schedule. To be safe, you should copy the 
scenario and schedule and just tweak the copy. Then, you would only commit the schedule you 
will actually use next year. Depending on the scenario preferences selected, attributes of each 
can be shared or they can be distinctly unique. 

Note:  

Differences between BCeSIS MTB versions and MyEducation BC scenarios: 

1. In BCeSIS students were mass simulated outside of a version.  In MyEducation BC 
students are loaded into scenarios.  This means you can go back to a previous scenario 
and students will still be in sections. 

2. In BCeSIS course scheduling attributes (length, format, etc.) were independent of the 
version.  In MyEducation BC course scheduling attributes are contained within each 
scenario.  This is also true for Staff, Student and Room attributes.  The exceptions are: 

a. Student course requests – these are shared amongst all scenarios and; 

b. Patterns and Pattern sets – these are shared amongst all scenarios. 

3. In BCeSIS scheduling in MTB need to be completed prior to YET.  In MyEd scenarios 
are Committed (to make a schedule the Active Schedule), after the Year End Process. 

 

1.1 Creating Scenarios 

1. Create the build scenario. 

2. Define preferences for the build scenario. 

3. Define the structure of the schedule you want to build with this scenario, such as the 
number of periods and days. 

You can also copy a scenario you create, and then edit only what you need to for the new 
scenario. 

Note: To rotate a scenario after you build a schedule, click the Rotations side-tab. 

 

1.1.1 To create a build scenario 

1. Log on to the Build view. 

2. Click the Scenario tab. 

Note: Using the Filter menu you can also view scenarios from previous years. 

3. On the Options menu, click Add. The New Schedule page appears. 
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4. Type a name for the scenario. If you plan to create more than one scenario for next year, 
use descriptive names. 

5. The system enters the start and end dates that coincide with the build context year. You 
can change these dates. 

Note: The Days per cycle and Periods per cycle appear after you define them. 

6. Type any comments. 

Note: Comments are very helpful if you will be creating multiple scenarios. 

7. Click Save. 

 

 

1.2 Scenario Preferences – Scenario Basic 

Define build scenario preferences that you want the system to consider when building the 
schedule with this scenario. 

During the School year, you can view the build scenario preferences for the current master 
schedule in the School view. Click the Schedule tab, and the Preferences side-tab. 

To define build scenario preferences: 

1. Log on to the Build view. 

2. Click the Scenario tab. 

3. Select the scenario.  

Note: It is advisable to always select the scenario by clicking on it, even when it is the only 
one available. Although the Build View displays the selected scenario below the school 
name, there can be a disconnect between the current year, school view and the build view 
scenario. This is particularly significant for those users with access to multiple schools. 
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4. Click the Preferences side-tab. 

5. The Category defaults to, Scenario – basic 

 

 

1.2.1 Schedule Expression Format 

The default for the schedule expression is Period first. The period is display in the schedule 
expression first followed by the day, P(D). All current year courses following conversion have 
been set with this default. The alternative is Day first, D(P). 

 

 

Recommendation:  It is recommended that districts decide on a standard format expression for 
schools to follow. The only indication of this setting in the School View is found from Schedule > 
Preferences which will display the preferences as shown above, for the current school year. 
Viewing schedule expressions as displayed within the application will not indicate the set 
preference. 
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1.2.2 Use Numeric Section Numbers 

Check this box to have the system generate numeric section numbers. Section numbers can be 
manually changed to alpha or alpha-numeric at any time.  If this box is checked it will ensure 
anytime a section is added, it will be sequential in numbering. 

Recommendation: Users should check this preference. 

1.2.3 Use Study Halls 

Checking this box will fill all unscheduled slots in a student’s timetable with a study hall. Courses 
with the required master type of Study have not been created at the Enterprise level, therefore 
this functionality cannot be used.  

Recommendation:  Users should leave this unchecked. 

1.2.4 Use Rotation 

Select this checkbox if you will be using a schedule rotation. This allows the rules defined to 
work within the rotated schedule; this does not trigger the rotation. 

1.2.5 Use Bell Schedule 

Check this box if your school uses more than one bell schedule. This would apply to schools 
such as a K – 12 school where the elementary students’ daily periods differ from those of the 
middle and/or secondary students.  If this is the case, special Rules need to be created and 
additional attributes assigned to courses and rooms. This selection is not necessary if bell 
schedules are used for the rotations of the schedule which can be done later, following the 
build. 

1.2.6 Control Inclusion Students 

Although the preference option is entitled, Control inclusion students, it must be stressed that 
students are not actually identified as “inclusion students” but rather; students have inclusion 
requests and course sections can be identified as inclusion sections. 

This preference setting provides the ability to control the inclusion requests to course sections 
identified as inclusion sections, either By ratio % of the class enrollment total, or By count with 
an overall limit set by number. 

This preference setting allows for controlling the number of those student requests identified as 
inclusion requests into the course sections identified as inclusion sections. For example, a 
school has three sections of MEN--09 all of which are set as inclusion sections and has 90 
students with a request for this course. Of these requests, eight are students with a request 
identified as “is inclusion section” checked. If the preference is set to, By count = 3, then the 
builder will drive three requests into one section, three into another, and the final two requests 
into the third section.  

The flag of inclusion is on the course request and not the students themselves. A given student 
may have a ministry designation assigned but might only have inclusion requests for English 
and Math, all other requests not being restricted by the inclusion preference setting.  This will be 
covered more thoroughly in Module 4: Student Course Requests. 
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1.2.7 Include Optional Requests 

Student course requests can be set as, Is optional. Where this is the case, checking this 
scenario preference will treat these requests as primary. This is rarely used and will be covered 
more thoroughly in Module 4: Student Course Requests. 

1.2.8 Use Reserve Seats 

Checking this preference allows for setting aside seats in a section of a course on the 
Workspace that can be filled after the schedule has been built. This feature could be useful in 
managing the number of students loaded into a section, to ensure space is retained for students 
arriving in Sept. or returning in the following spring. 

Examples: 

1. Hockey players who you know are coming to your school in Sept., but you don’t know 
who they are and therefore don’t have specific requests for them.  

2. International students, you know x number are arriving, but during the scheduling 
process you do not have requests for them.  

3. Hockey players returning, after their season is complete, and therefore require a seat in 
a section. 
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1.2.9 Use Content Term Code 

This preference is checked where schools will be offering students the means of completing 
term portions of a course where they did not meet requirements in an earlier attempt. For 
example as student did not pass semester one of a full year course, they could request to 
repeat only semester one of the course. Where this preference is not checked, the student 
request will be treated as that for the entire duration of the course. 

1.2.10 Show: Location, House, Team, Platoon, Section Type 

Checking these preferences controls whether these fields are displayed for use with student 
groupings in the Workspace, course section details and student details in the build view. Should 
the user expect to see any of these fields and does not, they only need to check the appropriate 
preference and save. 

 

1.2.11 Use Student Schedule Weight 

Select this checkbox if this scenario uses student schedule weights. 

By default students are scheduled with a weight of 1, which is interpreted by the builder as 
occupying one seat. If selected, this option displays a Schedule weight option on the student 
details in the Build View enabling the user to define this field. For example, a special needs 
student requires equipment and an aide. By assigning a schedule weight of 2; the course 
enrollment is now two seats closer to the maximum enrollment. 

 

1.3 Scenario Preferences – Scenario Advanced 

1.3.1 Engine Processing Time 

Recommendation: Do not change any of these preference settings: Teacher look ahead, Room 
look ahead, Schedule student. 

1.3.2 Max Count for Same Validation  

This preference setting limits the maximum number of times the system will display the same 
validation error when you validate your workspace. The default value for this field is set to 20. 

1.3.3 Use Shared Attributes 

Users can choose to share various scenario attributes which include: course attributes, staff 
attributes, student attributes, and time structure. Selecting any of these checkboxes uses the 
same attributes shared by other scenarios of the same build year. Changes to shared attributes 
are applied to all scenarios which have the given attribute checked. 

1.3.4 Relax Room Constraint 

Recommendation: Schools should not use this preference, rooms can be managed best using 
other means. 
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1.4 Scenario Preferences – School 

The only preference areas that can be adjusted are those indicated below and highlighted in the 
screenshot provided. Do not adjust student schedule workspace or any of the fields to the right. 

 

 

1.4.1 Schedule Mode 

Schedule mode must be set to Secondary for all schools. 

1.4.2 Elementary Schedule Grade Level Cut-off 

This setting has no effect with the schedule mode set to secondary. 

1.4.3 Pattern Day and Period IDs 

By default pattern day IDs are set as alpha and period IDs are set as numeric. These settings 
determine how patterns are displayed and how the schedule expression is displayed. For 
example, with a schedule expression format of period first the examples below shown from left 
to right would look like: 1(A), 1(1) and A(1) respectively to show period 1/day 1. 
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1.4.4 Section Number Pad Length 

Section number pad length refers to the system default length of the section number. This can 
be manually changed for any given section. The default setting is 3. 

Recommendation:  Do not set the length to 1. This can result in schedule issues should more 
than nine sections be required for a given course or courses. 

See Appendix A for a detailed table of scenario preference definitions. 

1.4.5 Copy a Scenario 

Users can create a new scenario copied from an existing scenario. If you copy a scenario from 
a different schedule build year, the system does not copy the term dates from that year.  

To copy a build scenario: 

1. Log on to the Build view. 

2. Click the Scenario tab. 

3. Select the scenario you want to copy, and click the Details side-tab. 

4. On the Options menu, click Copy Scenario. The Copy Scenario dialog box appears: 

 

 

 

5. Type a name for the new scenario. 

6. Select the checkbox of the items you want to copy from the original scenario to the new 
scenario. For example, you might want to carry over the rules created but not the 
student schedules. 

  



 

Scenarios, Preferences and Time Structures v1.2 Page 12 

1.4.6 Copy Active Schedule – Not to be used during a conversion year 

MyEducation BC provides the ability to copy the currently active schedule in the school to create 
a new scenario in the Build View. This scenario can then be used to create next year’s 
schedule. Schools are not to copy the current schedule in a conversion year as course 
catalogues are to be rebuilt to properly align with the correct ministry courses recently refreshed 
at the Enterprise level. 

After a school’s first build year with a fresh course catalogue, the copy active schedule will be 
an available option for schools. 

To copy the active schedule: 

1. Log on to the Build view. 

2. Click the Scenario tab. 

3. On the Options menu, click Copy Active Schedule. The Copy Scenario dialog box 
appears: 

 

 

4. Select the pieces of the active schedule you want to copy into this new scenario, such as 
the master schedule, student schedules, rules, and rotations. Select the Clear platoon 
code check- box if you want to clear the platoon codes associated with the active 
schedule. 

Note: Only checkboxes for items that apply to your scenario appear. For example, if the 
active schedule does not use a bell schedule, you will not see a Bell schedule checkbox. 

5. Click OK. 
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1.5 Terms 

Schedule terms are the date ranges during which a course can begin and end. Define the 
required schedule terms for your next year’s schedule.  

From the Build View, go to the Scenario top tab and click on the desired scenario. Go to the 
Terms side tab. Terms carried over from the current year will be displayed. It is important to 
click into the details of each schedule term. All schedule terms must have a schedule term code 
in the Schedule Term reference table. Some current year codes have been converted without 
existing in the reference table. These can be identified by an asterisk (*) beside the code. 

 

 

 

1.5.1 Adding Schedule Terms to the Reference Table 

To add schedule terms to the reference table, go to the Build View > Global > Reference > 
Schedule Term Codes > Codes > Options > Add. Enter a code that will be meaningful to the 
users and Save. 
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1.5.2 Adding and Defining Schedule Terms  

1. To add additional schedule terms go to Scenario > Terms > Options > Add. 

2. From the Code drop down list select the desired schedule term. If the term code 
representing the required schedule term does not appear, add the code into the 
reference table as described above. 

 

3. Use the following table to enter information in the fields: 

Field Description 

Code Select the code for the schedule term. For example, you might select FY 

for a full-year term, and S1 for Semester 1. 

Note: School users with the security role of Schedule Builder can create these 
schedule term codes from the Build View > Global > Reference > Schedule Term 
Codes > Codes > Options > Add 

Name Type a name for the schedule term. 

Base terms 
per year 

Type the total number of this type of schedule term in your schedule. For example, for 
a course that meets one-third of the year (a single trimester), there are three base 
terms. For a course that meets half of the year (a single semester), there are two base 
terms. 
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Field Description 

Term map Select the checkbox that represents which of the base terms this specific schedule 
term covers. For example, if you are defining Semester 1 and there are two base 
terms, select the first checkbox to indicate that this term is the first of the two terms. 

Note: The system displays checkboxes that equal the number of base terms you 
identify at the Base terms per year field. For example, if you identify 3 base terms, 
three checkboxes appear. 

Term date 
ranges 

Type or click to select the start and end dates of this schedule term. The system 
validates these dates against the school year dates. For example, you cannot enter a 
start date that is before the first day of the school year. 

Grade term 
cover map 

For reference, you can type the grade terms that will be recorded during this schedule 
term. For example, if you are defining the Semester 1 schedule term and your school 
operates with quarter grade terms, you select the first two checkboxes. This indicates 
to the system that a value will be entered for the first two terms within this schedule 
term, but not the last two. 

 

4. If schedule terms exist that are not required, these can be deleted by clicking into the 
details of the schedule term and going to Options > Delete. 
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1.6 Days 

Your schedule might consist of several days per schedule cycle. This way, students can attend 
different classes on different days in a schedule. Many schools follow a flat, two day schedule 
where full year courses are offered on a day 1 or day 2 while the semester courses are offered 
on both. Schools that offer back to back or double blocks of courses where attendance is taken 
in both blocks will require a rotated schedule. In order to accommodate the full rotation schools 
may have multiple days. For example, a school that has eight rotations for their cycle to 
complete would need eight days for their rotated schedule. 

To define schedule days: 

1. Log on to the Build view. 

2. Click the Scenario tab. 

3. Select the scenario you want to work with, and click the Days side-tab. 

4. On the Options menu, click Add. The Add Day dialog box appears: 

 

 

 

5. At the Day count field, type the number of days in the schedule scenario. For example, if 
you are adding another day to a list of existing days, increase the number by one. The 
dialog box displays the appropriate number of rows, with each row representing one day. 

6. For each day, type an identifier in the Identifier column. 

Note: It is suggested using different identifiers for days and periods. For example, if you 
use letters for periods, use numbers for days. 

7. Type a name for each day in the Name column. 

8. Click Save. 
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1.7 Periods 

Define the number of periods in your schedule. 

To define your periods: 

1. Log on to the Build view. 

2. Click the Scenario tab. 

3. Click the Periods side-tab. 

4. On the Options menu, click Add. The Add Period dialog box appears: 

 

 

 

5. In the Period count field, type the number of periods in this schedule scenario. The 
dialog box displays the appropriate number of rows, with each row representing a 
period. 

6. For each period, type an identifier in the Identifier column. 

7. For each period, type a name in the Name column. 

8. Click Save. 
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1.8 Bell Schedules 

During the 'prepare to build' schedule process, you might want to define your school’s bell 
schedules. 

Note: If your school uses more than one bell schedule during the same schedule day, you need 
to define bell schedules before you build. Otherwise, you can wait to define your bell schedules 
in the School view, after you commit your schedule. As, schools in BC have done. 

When you define your bell schedules, you define the start time and duration for each schedule 
period in your school. Then, when you validate your 'prepare to build' data, the schedule engine 
checks for any conflicts arising from the bell schedules. 

Not all schools need to define bell schedules. You need to define bell schedules for one or more 
of the following reasons: 

1. Your school has periods that overlap. For example, some schools have lunch spanning 
three   periods – 4, 5, and 6. You need to define the times of these periods to determine 
if and when there is a schedule conflict. 

2. Some schools have shorter periods in the afternoon (20 minutes) than in the morning 
(40 minutes). You need to define bell schedules to determine schedule conflicts for 
students. 

3. Grades in the same school might have different schedule shapes. For example, 5th, 6th, 
7th graders might operate with a 2-day/6-period schedule, and grades 8-12 might 
operate with a 2- day/4-period schedule. Because you can only define one schedule 
shape per school, you can use bell schedules to differentiate between the two 
schedules. If you create more than one bell schedule for your school, you must use Bell 
Schedule rules to assign the appropriate bell schedules to rooms and courses. 

Note: If you want the build schedule engine to reference bell schedules when building the 
master schedule, select the Include in scheduling checkbox when defining bell schedules. 

Note: To copy bell schedules from a previous year, on the Options menu, click Copy From. 
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To define bell schedules: 

1. Log on to the School view. 

2. Click the Schedule tab. 

3. Click the Structure side-tab, then click Bell Schedules. 

4. On the Options menu, click Add. The New Schedule Bell page appears: 

 

5. Type a unique identifier, name, and description for the bell schedule. 

6. Select the Include in scheduling? checkbox if you want the build engine to use this bell 
schedule to schedule sections to avoid conflicts. 

7. In the Number of days field, type the number of days in this bell schedule. 

8. At the Combine day’s field, click   to select multiple days that can feed to the 
particular bell schedule day. This allows different days' schedules to appear on one day 
on the fly without modifying the actual schedule.  

9. For each period, define the start time and duration. 

Note: The start time for each period does not have to be sequential like the period 
number order. This way, you can change the order of periods on the fly for a particular 
day without modifying the actual schedule. This is what most schools, in BC have done 
to `Rotate’ their schedules. 

10. To add an additional period for an after-school program, or another extra period not in 
the academic schedule, click Add. The Add Bell Period dialog box appears. Define the 
period number, 
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Appendix A: Scenario Preferences Table 

Field Description 

To define basic preferences: 

Schedule expression 
format 

Select one of the following to determine how you want your days and periods 
to appear on the master and student schedules: 

 Period first 

 Day first 

 

For example, if you select to display period first and your schedule contains 7 
periods (1-7) in a six-day cycle (A-F), and a section meets period 2 on days 
A, 

 

Note: You might want to use one alpha character and one numeric to avoid 
confusion. For example, the schedule expression for Period 1, Day 1 would 
be 1(1). 

Use numeric section 
numbers 

Select this checkbox if you want the system to generate numeric section 
numbers. 

Note: If you select this option and later add a course section, the system will 
automatically populate the section number field with the next available 
number. 

Use study halls Select this checkbox if you want the system to schedule students in study 
halls when their schedule permits. 

Use rotation Select this checkbox if you want the system to consider the schedule rotation 
when building the master schedule to prevent certain rules from breaking, 
such as the teacher’s max-in-a-row value. 

Note: This checkbox doesn't trigger the rotation to happen. 

Use bell schedule Select this checkbox if you are going to use one or more bell schedules to 
create a schedule with this scenario. Rarely used. 

Note: If you plan to use more than one bell schedule, you need to define bell 
schedule rules to assign the appropriate bell schedules the appropriate 
rooms and courses. 
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Field Description 

Control inclusion 
students 

Click this drop-down menu to select one of the following: 

 By ratio (%) to control the ratio of inclusion students in inclusion 
sections by a specific percentage. Type the percentage in the field. 

 By count to control the ratio of inclusion students in inclusion sections 
by specifying the exact number of students the system can schedule 
in each inclusion section. Type the number in the field.  

 For example, a school can determine that inclusion sections can only 
contain four inclusion students (By count), or 10% of inclusion students (By 
ratio %). 

Notes: 

 If you do not define a number or percentage of inclusion students, 
you could inadvertently fill a class with all inclusion requests. 

 This works off of the actual enrollment, not the enrollment max. For 
example, if the enrollment max is 30 and the inclusion ratio is 50% 
and 12 non-inclusion students are enrolled, a maximum of 12 
inclusion students will be sched uled in the class. 

Include optional 
requests 

Select this checkbox if optional requests are considered primary requests in 
this scenario. Optional requests are primary requests that can be ignored 
under some conditions. 

Note: This option provides an easy way to remove particular requests without 
deleting them. For example, you might need to investigate decreasing your 
current 8-period day down to a 6-period day. You could mark some requests 
as optional and then deselect this checkbox. 

Use reserve seats Select this checkbox if you want to enable reserve seating for all course 
sections. You can set aside a number of seats in a section on the Work- 
space, which you can fill after the schedule has been built. 

Use content term code Select this checkbox if you want the system to use the content term codes 
you define for sections when building this scenario. 

For example, maybe you want to allow students who fail part of a full- year 
course to retake that portion of it. 

Note: This field is related to the Content term code on the student request. 
Remember that if a student fails first semester of a full-year course, they can 
request S1 only. The engine schedules the student in a section, but notes 
that the student is enrolled for the content term code only. Also, the student 
appears in the teacher’s gradebook for that term only. 

If you do not select this checkbox, the system ignores the Content term 
code on the student's request, and schedules the student for the entire 
duration of the course. 

Show location, Show 
house, Show team, 
Show platoon, Show 
section type 

Select these checkboxes if you are going to use these student grouping 
options when building this scenario. The grouping fields (team, house, etc.) 
only appear on the Details page for a section on the Workspace tab if you 
select these checkboxes. 
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Field Description 

Use student schedule 
weight 

Select this checkbox if this scenario uses student schedule weights. 

The system uses student scheduling weights when building and you have 
determined to close sections at maximum enrollment. 

By default, students have a schedule weight of 1. You might define a weight 
of 1.5 or 2 to determine specific students fill more than one seat due to his or 
her IEP requirements. 

Define student scheduling weights for each student in the student scheduling 
preferences. 

Note:You can determine that specific courses do not use schedule weights. 

To define advanced preferences: 

Engine processing time 
(seconds) 

Type the number of seconds you want the system to use to look ahead to 
teachers and rooms when trying to schedule a course. 

Use these fields when you are building the workspace and the scheduling 
engine is stopping repeatedly when it attempts to schedule courses because 
of teachers or rooms. 

Defining seconds in these fields allows the scheduling engine to look for 
unassigned teachers or rooms for the number of seconds you identify, 
instead of immediately presenting you with a conflict. 

Note: Entering a half-second adds significant processing time, and should 
help the system find the appropriate teachers or rooms. 

Max count for same 
validation 

Type the maximum number of times you want to view the same validation 
error when you validate your workspace. The default value for this field is 20. 

Use shared attributes: 

 Course 

 Staff 

 Student 

 Time structure 

If you select any of these checkboxes, the current scenario uses the same 
attributes shared by other scenarios of the same context year. The system 
applies any changes you make to these attributes to the other scenarios. 

If you do not select this checkbox, the current scenario has its own set of 
attributes. Any change made to these attributes belongs to the current 
scenario only. 

Note: For example, if you share staff attributes and delete a staff member 
from one scenario, that person will automatically be deleted from any shared 
scenarios. Therefore, to minimize confusion and possible errors, it is 
recommended that you do not select these checkboxes. 
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Field Description 

To define school preferences: 

Schedule mode Only select the following: 

 Elementary 

 Secondary 

 Both 

Elementary schedule 
grade level cut-off 

Type the grade at which the schedule shifts to Secondary mode. This only 
applies if you have selected Both in the Schedule mode drop-down menu. 

Pattern day IDs /  

Pattern period IDs 

Type the default day and period IDs for school patterns. The system default 
values are: 

 A-L for day IDs 

 1-20 for period IDs 

Section number pad 
length 

Type the maximum number length for a section number. The default value is 
3. 

Note: Keep leading zeroes for sorting purposes. 

Student schedule sort 
order 

Type the student schedule sort order using the Java name for fields. The 
system uses this order to sort the student schedule list in both the School and 
Build views. 

The default value is 
scheduleDisplay,termView,masterSchedule.scheduleTrackId, 
masterSchedule.courseView. These values are ones found in the 
JavaName field for the field in the Data Dictionary. 

Student schedule 
matrix cell 

Type the fields used in the student schedule matrix. 

Student schedule workspace 

Student schedule fields Type the columns to appear on the student schedule workspace you use to 
manage student schedules 

Master select fields Type the columns that appear in the master schedule pop-up window when 
you add a section to a student's schedule on the student schedule 
workspace. 

Add / drop align date 
window (days) 

Type the number of days after the school year starts that student schedule 
adds/drops need to be aligned. 
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Field Description 

Number of sections 
deleted with warning 

Type the minimum number of sections being deleted that will prompt a 
system warning upon deletion. 

Schedule on client 
machine 

Select this checkbox to run the scheduling engine on the user’s workstation 
instead of the server. 

Notes: 

 The primary purpose of this feature is to conserve server processing 
resources. If many users are running builds and loads at the same 
time, server performance can be affected. Running the engine locally 
leverages the workstation’s processing power to reduce the load on 
the server. 

 If you select this checkbox, the user who builds the schedule must 
specify where the scheduling engine should write files to when they 
set their user preferences. 

Shared build year 
scenario 

Select the build scenario that contains sections that will be taken by incoming 
secondary students. 

Allow build year 
request edits 

Select this checkbox to allow the school to manage requests for incoming 
students (based on a student's next school). 

Align teacher 
assignment with 
certification 

Select this checkbox to indicate if a teacher is certified to teach a course 
when creating teacher assignments. 
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