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1.0 Entering and Viewing Student Requests 

One of the most important and time consuming tasks in preparing to build your master schedule 
is collecting, entering and validating student course requests.  

Requests are 'fuel' for the scheduling engine. The engine attempts to build the schedule that is 
best for students based on their requests. 

There are a variety of methods to enter and manage requests.  Use one or a combination of the 
following methods to enter student requests: 

 Enter requests for one student at a time from either the School view or the Build view. 

 Mass entry of requests using Multi Add, in the Build view. 

 Batch Entry of student requests by typing student IDs and course numbers into a grid, in 
the Build view 

 Course packages. 

 Student online selection (not covered in this document). 

 

Once requests are entered, there are several ways to view student requests. Use the table 
found in Appendix A to determine how you want to view student requests. 

 

2.0 Individual Entry of Student Course Requests 

Student course requests can be entered for one student at a time from either the: 

School View > Student > Schedule > Requests or; 

Build View > Student > Requests. 

Note: Using the School View for entering individual student requests will display the student’s 
grade along with their name.   the Build View displays the student’s pupil number and name, 
with no grade shown. 
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2.1 Primary Requests 

2.1.1 Entering Primary Requests 

From the student requests screen shown below, primary requests are entered in the upper 
block. This can be done by entering the course codes separated by a comma and then clicking 
the Add button. Requests can also be added using the Select button, multiple courses can be 
chosen. 

Note: When using the Select feature, the grade level in the pick list represents the grade level of 
the courses the student will be selecting from for the next school year. 
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2.1.2 Attributes of Primary Requests 

Upon entry, student requests are all primary requests with no restrictions or constraints. 
Attributes can be assigned to requests helping direct the scheduling and load engines.  

Click on the details of a course request to set attributes. 

 Section Type:  

o Section Type Codes can be added to the reference table. To access the codes 

go to: Build View > Global > Reference > Section Type Codes > Codes > Options 

> Add. Course sections can then be set as a section type thereby driving 

students with these requests into the appropriate groupings. 

 Is Inclusion Section:  

o Check to indicate an inclusion request. Scenario-basic preferences control the 

number of inclusion students for course sections identified as inclusion. 

 Content Term Code:  

o If the school is offering students the option of completing portions or terms of a 

course that perhaps they failed in an earlier attempt, this provides the means to 

select the term to repeat. 

 Is Optional: 

o Where a course may be offered but is yet to be determined, this choice can be 

selected. Choosing, Is optional sets the request as a Primary request should the 

course be offered but will be ignored without the need to delete if the course is 

dropped. Scenario preferences will need, Include Optional Requests checked if 

this is used. 

 Staff Name, Section Number, Term Code: 

o Each of these fields is available to set constraints on a request. This limits the 

builder’s ability to find a “best fit” for the schedule. 
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2.2 Alternate Requests 

There are two main types of alternates provided in MyEducation BC. General alternates refer to 
those course requests that would be over and above the primary requests. For example, if a 
student does not get a primary request then an alternate will be substituted. The other type is a 
direct alternate which is specific to a particular primary request. For Example, if a student does 
not get into the Woodwork course, substitute with Metal Fabrication instead. 

 Is Alternate Course: 

o Checking this box sets this request as a general alternate selection. 

 Alternate Course Priority: 

o Students are likely to be allowed more than a single alternate request, this option 

allows for a priority to be set on the alternate request. If a priority is not set, all 

alternates are treated equally by the build engine. 

 Alternate Course Type: 

o Two alternate types are available 

 Substitute: This is the default and will use this alternate request to 

substitute for a primary request not granted. 

 Auto-full: This option will use the alternate requested to fill any openings 

in a student’s schedule; this includes out of the regular day periods too.  

 Alternate Course Number 1 and 2: 

o This sets a direct alternate request for the primary request indicated at the 

School Course > Number field. If the primary request cannot be met, then first 

choose alternate number 1, if this cannot be scheduled then choose alternate 

number 2. 
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3.0 Mass Entry of Student Course Requests 

The various methods of mass entering, updating and managing course requests in bulk, is done 
in the Build view. 

3.1 Multi Add 

Using the multi add function, you can easily add requests by course number for a group of 
students you select or an entire grade level or snapshot. 

Note: Keep in mind that any information on the Global tab - including requests - is shared 
across all of your scenarios.   It is therefore possible to  delete all course requests for students – 
use caution when deleting! 

 

To add student requests for a selection of students or a snapshot: 

1. In to the Build view. 

2. Click the: 

a. Global tab > Requests >  Options > Multi Add…or 

b. Student tab > Options > Multi Add Requests…or 

c. Courses tab > Options > Multi Add Requests… 

3. The Multi-Add Request dialog box appears: 

 

Note: You can also click the Student tab or the Courses tab. Then, select the appropriate 
students or courses, and click Show Selected on the Options menu. After you click Multi-Add on 
the Options menu, choose Current Selection to enter requests for the students or courses you 
selected. 
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3.2 Course Packages 

Create a course package to quickly enter requests for a group of courses several students must 
take.  The course package is only a holding course used during the scheduling process.  These 
special courses have been defined at the enterprise level with a master type of package.  This is 
how the system knows they are different.  The following courses with a master type of package 
have been created; districts and/or schools can make copies of these (just like other courses) 
as required. 

 

 

For example, assume next year’s Grade 8 students all take the same set of courses at your 
school.  You can create one course package and include all courses within it. This way, when 
you enter the request for the course package and expand that package in the Build view, the 
system automatically enters a request for all courses. 

Note: In MyEducation BC, students that are going to be in an elective rotation (wheel) need to 
have requests for those courses.  
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3.2.1 How to build a course package (this can also be done in Build view): 

1. Log on to the School view. 

2. Click the Schedule tab. 

3. Click the Courses side-tab. 

4. Find the course package and click Details. 

5. At the bottom of the page, in the Course package area, type in all the Course Numbers 

separated by commas that will be part of this package:  

 

6. Click Save. 

Notes: If any of the course numbers are incorrect the application will not allow you to Save until 
it is corrected. Also, it may be preferable to work in the school view rather than the build view 
because if you need to make copies of your courses or packages, i.e., PKG--09-COR and  
PKG--09-EXP, then this must be done in the school view. 

The next step is to give students the Request for this course package.  This can be done using 
the Multi Add function covered in the previous section.  
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3.2.2 Expanding Packages 

Once students have been given the request for the package, it needs to be Expanded. 

1. From the Build view > Global top tab > Requests side tab, you can see all current grade 

07 students have the request for PKG--08---Reg and there is a total of 163 Requests: 

 
2. Options > Expand Packages (this will expand ALL course packages) 

3. Once expanded you can now see students have a request for each course contained 

within the package: 

Note: The package course remains should you need to collapse the package. 
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3.2.3 Collapsing Packages 

If for some reason you want to bring put students back to just having a request for the package 
you can Collapse it back (this will be done for all packages). 

1. From the Build view > Global top tab > Requests side tab 

2. Options > Collapse Packages 

3. All students again have only a request for the package: 

 

 

3.3 Batch Entry 

Batch entry of student course requests works very well when students are provided a course 
selection sheet to submit for entry. This feature is very similar to the Option Sheet Entry method 
in BCeSIS. This option also provides the ability to have a good visual inspection of students who 
may be short of course requests. 

Batch entry of requests is accessed from: Build View > Global > Requests > Batch Entry. 

 Parameters are available for setting the matrix which includes the number of students 

per batch, the number of primary requests and the number of alternate requests.  

 Groups of students can then be either individually selected, selected by grade(s), or by a 

snapshot. Students can also be pulled by entering their pupil number into the ID field at 

the far left. 

 Course requests are then entered by clicking in a cell and typing in the course code. 

Only valid course codes for courses existing in the build year will be accepted by the 

system. An error message will pop up if the code does not match a build year course 

code. 

Note: The cell presented for manually entering pupil numbers and course codes does not give 
the ability to see the entire entry; this is especially true using Internet Explorer. Copy and 
pasting course codes ensures accuracy. 
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3.4 Filter Requests and Filter Students 

MyEducation BC provides a tool to filter student requests and a tool to filter students. Both allow 
the user to scope down to a specific subset of students.   

3.4.1 Filter Requests 

Filter requests provides a means for the user to find students who have requested a particular 
course or group of courses and then for these students to show a selected course or courses. 
This feature is very handy to pull students with particular combinations of courses. If a course 
was accidentally assigned to a group of students, this is a quick method for isolating those 
students and the incorrect course and then removing it from their requests. 

Filter requests is accessed from the Build view > Global > Requests > Options > Filter 
Requests. 

 The upper block is used to identify the students with all (Intersection) or any (Union) of a 
chosen group of courses, or single course. 

 The lower block determines which course request or requests will be displayed for the 
students identified using the upper block filter. 
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In the example shown below, requests are filtered to show all students with requests for both 
MAWM-10 and MTEM-10; but only show MPLAN10 for this selection of students. 
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3.4.2 Filter Students 

Filter students allows the user to find students based on grade, homeroom, or  
house/team/platoon code that have a course or courses with a given schedule status. This can 
be a handy tool for locating students that may be missing a required course as in the example 
shown below where 4 students are identified as missing Planning 10. 

 

Filter students is accessed from the Build view > Student > Options > Filter Students. 
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4.0 Reports 

There are several reports that can be used to analyze and assist with the management of 
course requests.  

4.1 Course Request Verification report 

This report is run from the Global > Requests > Reports, lists all students and the individual 
requests each has. 

 

 

4.2 Course Request Tally report 

This report, is run from the Global > Requests > Reports.  If this is ran with the parameter of 
Show calculated section counts, the Section Count column will show decimals. 
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4.3 Course Request List report 

This report is run from the Courses top tab.  It shows a list of all students who have requested a 
course. 

 

 

4.4 Student Request 

This report, is run from the Global > Requests > Reports and shows each students requests on 
one page. 
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5.0 Appendix A: Viewing Student Course Requests 

To view 
requests by: Do the following: 

Course 1. Log on to the Build view or the School view. 

2. In the Build view, click the Courses tab. In the School view, click the 

1. Schedule tab, then the Courses side-tab. 

2. Select a course, and click the Requests side-tab. All student requests for that 
course appear. 

Note: Use the Filter drop-down to select Build year or Current year to view the course 
requests you want. 

Student 1. Log on to the Build view or the School view. 

2. Click the Student tab, and search for and select the student. 

3. Click the Requests side-tab. 

Note: The request page displays the school year context, total number of primary and 
secondary requests, scheduled percentage and total credits. 

All requests 1. Log on to the Build view. 

2. Click the Global tab, and the Requests side-tab. All requests entered for the build 
year for the current scenario appear. 

Note: On the Options menu, click Filter Requests to view a specific group of requests. The 
Requests Filter dialog box appears. You can search for students requesting the same 
courses, or some of the same courses, or search for students in the same house, team, or 
platoon. 

 

 

 

 


